Back to overview
Maintenance
Upgrades
Apr 16, 2026 at 2:00am UTC
–
Apr 16, 2026 at 3:00am UTC
Affected services
TNABoard United States
Billing Systems
Bitcoin Server
TNABoard Australia
Resolved
Apr 16, 2026 at 3:00am UTC
Maintenance ended
Affected services
Created
Apr 16, 2026 at 2:00am UTC
There will be scheduled maintenance tomorrow 15th April between 7:30pm and 8:30pm PST. There will be multiple downtime periods during this hour.
Affected services